Firefox 18 works fine, just reload Cocoon after updating Firefox and everything is back to normal. Rated 3 out of 5 stars

When I'd updated to FF 18 it told me that Cocoon wasn't compatible with the latest and greatest FF. I was very annoyed, sent off a nasty email, then thought for a second, used my head, just reloaded and re-installed Cocoon and it worked (and works) like a star. So If you're having comparability issues w/new FireFox; you might want to check into doing this on your puter if you have problems after new Fireforx.

This review is for a previous version of the add-on (vb-20120830181920.1-signed.1-signed).  This user has a previous review of this add-on.