No longer compatible with FF 23 beta and newer Rated 1 out of 5 stars

Voyage doesn't work on FF 23.0 Beta and on the latest 25.0 nightly.
Is this addon still supported/developed?