Not working on Firefox 8 or 9 Rated 5 out of 5 stars

I am using Vocabulary Highlighter 0.7 on Firefox version 7.0.1 and the addon is working great. However, it won't work on Firefox version 8 or 9. Nothing highlights. Yet, the version number says it is compatible to version 9. I have updated to the latest beta 8 and disabled all my other addons but still nothing.

This review is for a previous version of the add-on (0.7).