Need for Update Rated 5 out of 5 stars

Hi,
I am using this theme from last 8(nearly) months.
I really liked this theme.

Now this theme doesn't supports firefox 3.5. I am eagerly waiting for the support of this theme for the latest version.

Please update this theme as soon as possible.

Again thanks for providing this simple and nice looking theme.