Great addon, but what about FF4? Rated 5 out of 5 stars

It is a great addon. Addon freak as me (60+) and wanting to be always up to date, really saves me a lot of clicks in the "Check for updates" :) But now FF4 version is needed.
Is it in the plans?