install.rdf needs an update Rated 4 out of 5 stars

install.rdf needs an update, It says Works with: Firefox 2.0a1 - 7.* but is wrong.
Install.rdf says maxVersion="6.0a1" I had to change it to maxVersion="6.*" cause FF 6.0 kept disabling it

This review is for a previous version of the add-on (0.4.24.1-signed). 

Thanks. Fix Released.

Hi dobbelina. Thanks for notifying me of this issue. It has been fixed in the newest version of Universal Print.