Needs 3.6 update Rated 4 out of 5 stars

Needs update for FF 3.6. Thanks!

Also, the homepage link does not go to the add-on.