Awesome addon - almost perfect... Rated 5 out of 5 stars

Hi Iago,

> Bug number 2: I can't confirm, but knowing the problems I had in the past with synchronisation between Unified Search
> options and Quick Filter options, all is possible ;-). Synchronisation is being harder than I believe when started this extension.
> If you can give me some extra info I thank you:
> - What operating system and version?

Windows XP Pro sp3 fully patched

> - What Thunderbird version?

5.0

> - When this bug happens you,
> - are you using the horizontal criteria bar or the vertical criteria menu (where are the filter options, horizontal or vertical)?

Horizontal

> - all options checked in Unified Search are the same are checked in Quick Filter toolbar?

Yes

> About bug 'the labels for the criteria are totally blank on mine', I don't understand well what meaning: Texts are missing? Every time?

Yes

> When texts/labels are missing, labels in Quick Filter toolbar are missing too?

Yes

> What screen size are you using?

24" LCD, 1920x1080

Great work Iago on this fantastic addon...However, there is one problem I've noticed, and one thing missing...UPDATE: Another bug - right now, the labels for the criteria (Sender, Recipients, Subject, etc) are totally blank on mine...******************************1. Missing is the auto-clear functionality that the Quickfilter searchbox exhibits when you switch to a different folder...Yes, the search is no longer applied (as long as you haven't stickied it), but the contents of the search box is not cleared, when it should be.2. I have had problems with the search criteria getting confused/out of sync, where I get zero results when I know there are emails that match the criteria I have entered.In order to 'fix' the problem, I have to open the Quickfilter toolbar, and deselect and reselect the desired criteria (normally just 'Subject, Sender and Recipients'), then it will find the results...I haven't figured out how to reliably reproduce the problem, but it happens often enough that you should be able to if you're looking for it.Otherwise, an essential addon for TB5+!

This review is for a previous version of the add-on (0.6.0). 

Hi Tanstaafl_bh,
I confirm your bug number 1: auto-clear don't work if selected folder is changed (only works if quickfilter bar is opened, what is not usable). I am looking for a solution.
Bug number 2: I can't confirm, but knowing the problems I had in the past with synchronisation between Unified Search options and Quick Filter options, all is possible ;-). Synchronisation is being harder than I believe when started this extension. If you can give me some extra info I thank you:
- What operating system and version?
- What Thunderbird version?
- When this bug happens you,
- are you using the horizontal criteria bar or the vertical criteria menu (where are the filter options, horizontal or vertical)?
- all options checked in Unified Search are the same are checked in Quick Filter toolbar?

About bug 'the labels for the criteria are totally blank on mine', I don't understand well what meaning: Texts are missing? Every time? When texts/labels are missing, labels in Quick Filter toolbar are missing too? What screen size are you using?

UPDATE: bug 'labels are blank' fixed in 0.6.1 version, I'm working to fix the others 2 bugs (I filed like issue#2 and issue#3 at github), but I found a Thunderbird bug that involves into the problem of out-of-sync:
Bugzilla.mozilla.org bug 582576 (https://bugzilla.mozilla.org/show_bug.cgi?id=582576), when switch to Account Central (the root folder, that doesn't contain messages only account options), quick filter options are preserved but not applied when go again to a normal folder (it seems de-synchronized; this happens with all extensions disabled too). I'm working to create a workaround for this and solves bugs 2 and 3 in the version 0.6.3. More details and further advances at github.com.

Thanks very much for the feedback,
IagoSRL