Abandonware, but still useful Rated 4 out of 5 stars

I can confirm that as grahamc has posted it is possible to use this with current versions, such as TBird 12.x

Just install Disable Add-on Compatibility Checks:
https://addons.mozilla.org/en-US/thunderbird/addon/checkcompatibility/?src=search