Rated 1 out of 5 stars

"Not compatible with Firefox 3.6.16"
I cant use this addon until you update it for the latest version of firefox!

This review is for a previous version of the add-on (1.1.1-signed).