Rated 3 out of 5 stars

It works when it manages to start. Ever since I updated to Firefox v26, it is a 50:50 chance that this plugin is enabled. Sometimes it starts, and sometimes it gets disabled saying it is not compatible with this version of Firefox. Same problem has carried forward to Firefox v27 also.

Please fix this inconsistency.