Rated 5 out of 5 stars

This looks to be exactly what I want for handling Tab Groups; but I can't use it because it's not compatible with the most recent version of FF. (EDIT: that was a prompt response; thank you!)

This review is for a previous version of the add-on (0.9.1.1-signed). 

Install

https://addons.mozilla.org/en-US/firefox/addon/checkcompatibility/?src=ss

to make it compatible.