10.0 Rated 5 out of 5 stars

Not compatible w/ FF 10.0! PLEASE update.

This review is for a previous version of the add-on (1.1.2).