Rated 1 out of 5 stars

Upon installing, it says it is not compatible with FF 3.6.9...