Rated 5 out of 5 stars

Works in Firefox 3.6 if you alter the max version number in install.rdf

Nice.