Rated 3 out of 5 stars

It doesn't appear to work with Firefox 4.0b11 under Linux, at least not with Twitter. I've reported this apparent incompatibility along with a list of installed add-ons via the Add-on Compatibility Reporter.

(I gave 3 stars as it appears to work for others, and I couldn't bring myself to give 1 star for incompatibility with beta software under a minority platform)

This review is for a previous version of the add-on (1). 

This is more than likely a conflict with another add-on. I know at least one popular add-on it doesn't play nicely with. Hoping to get that fixed soonish.