Rated 4 out of 5 stars

Need support for Firefox 4.0b11, because it worked great on the older versions! :D