Update? Rated 5 out of 5 stars

Very good extension, but this one other extensions are blocking me from migrating to Firefox 3.5.1. Is there going to be support any time soon?
I am not pushing just asking :)

This review is for a previous version of the add-on (1.0.6).