doesn't work Rated 1 out of 5 stars

no version is available thats compatible with the firefox 4 final release.

This review is for a previous version of the add-on (0.2.22).