Rated 5 out of 5 stars

For me, thats addons must have every firefox 4 user because FF team remove addons completely.
Sorry my late reviews :P.

This review is for a previous version of the add-on (2010.10.12.19).