Rated 5 out of 5 stars

If Spellbound isn't going to be compatible with FF 4 then I'm sticking with FF 3.6. That's how good this add-on is.

This user has a previous review of this add-on.