Rated 5 out of 5 stars

can you make this add-on work on firefox 3.5 please?
i need it a lot