version compatibility Rated 4 out of 5 stars

needs to be updated... please?