Rated 4 out of 5 stars

I (not only) won't update FF from 19 until this addon is fixed to work with the current version. Period.
FF20 and 21 have broken so many things, and removed useful features, and while some of the other problems can be alleviated with addons or other means, this addon does not have good alternatives for me.
With every other version FF breaks so many good addons that it becomes a real problem again. Aren't they supposed to fix bugs and not messing around in a way to break addons every month or so...?!

This review is for a previous version of the add-on (0.45.6.20100202.1.1-signed.1-signed).