Rated 5 out of 5 stars

Please update it for Firefox 5.0
I would like to use it

This review is for a previous version of the add-on (1.0725). 

Actually It is compatible with Firefox 5, would you please kindly check or try to download it again?

Thanks for your support anyway!