Need version for FireFox 4 Rated 3 out of 5 stars

Some users of the version available here will probably be like me and install the version directly from their website. I have 0.5.23s. The problem is that this version doesn't work with FireFox 4. It's not like they didn't know FireFox 4 was coming (for months and months and months...). That's just sloppy work.

This review is for a previous version of the add-on (0.5.21amo.1-signed.1-signed).