Really compatible with FF4 ?? Rated 3 out of 5 stars

The add-on is marked as "Incompatible with Firefox 4", so I am unable to install it on my FF4 (even when trying to "force" the installation)

This review is for a previous version of the add-on (0.9.0).