Rated 1 out of 5 stars

States not compatible for FF4..can't install. Why?

This review is for a previous version of the add-on (0.9.0).