Pretty good, BUT... Rated 4 out of 5 stars

Useful add-on - but please, please, remove the notification on closing FireFox, or at least make it a configurable option. I wanted to revert to version 3.5 until this is fixed, but couldn't because the older 3.5 version would not install into the FireFox 4.0.1 I'm running (contrary to what it says about it on the older versions page). To work around this, I had to modify the install.rdf file embedded in the selectivecookiedelete-3.5-fx.xpi file and change em:maxVersion to "4.0.*" which had been set to only "3.5". After doing this I was able to install the older version of the add-on which doesn't have the annoying notification added in the latest update.

UPDATE: I've posed a version of the v3.5 .xpi file with em:MaxVersion in the install.rdf file set to "6.*" so it should be able to be installed in Firefox versions 1.5 - 6.* (as it claims on the Version History page) here:
http://dl.dropbox.com/u/5508445/firefox/selectivecookiedelete-3.5-fx-MOD.xpi

Please note however that I have not tried it with anything newer that Firefox 4.0.1 -- so your mileage may very.

This review is for a previous version of the add-on (4.0.1-signed.1-signed). 

Version 3.5 is compatible with Firefox 6.0

Please use version 3.5 directly from the addon page, instead of from third party sites. Or download new version from
https://addons.mozilla.org/firefox/downloads/file/126558/selectivecookiedelete-4.1-fx.xpi