Similar addon for modern FF versions Rated 5 out of 5 stars

Here is similar addon, supported by modern FF versions: https://addons.mozilla.org/firefox/addon/secure-password-generator/

Working version for FF4/5 Rated 5 out of 5 stars

I had the same problem starting with Firefox 5.

The problem arises from the missing "chrome.manifest" - I created one, increased the version to 0.5.5 and set it to be compatible with up to Firefox 5.*:

Original/English version: http://ul.to/7x9atjam
German version: http://ul.to/085cxzjd (thanks to http://www.erweiterungen.de)

THANKS to Jeremy!

rethink your add-on Rated 1 out of 5 stars

I think this Add-on has problems! I installed it and then it never showed up in the tool bar, I then went to Add-ons and clicked on the options and it locked Firefox up and it was task manager time...I RE-started firefox and uninstalled then re-installed and restarted firefox and same problem, never showed in tool bar and when I went to the add-ons and again clicked on "options' the program locked up again so the rating is less than Zero. You got a star because the review gurus said I had to.

Rated 1 out of 5 stars

Great, it makes your Browser hang or crash! Jeremy, fix it or remove it!

3.6 support Rated 1 out of 5 stars

Anyone able to get his working, or are there plans on making it compatible with the new 3.6.2?

Rated 1 out of 5 stars

Also finding this crashes the Add-ons window when clicking the "options" button for this extension.

Shame, I used to find this add-on useful.

locks up Rated 1 out of 5 stars

does not work with 3.6/locks up add-on boxx, basically crashes browser.

Rated 4 out of 5 stars

I love this add on and have used it from 1.0ish, but the consistent compatibility issues is kind of annoying.

I created another password generator inspired by this add-on and to help between compatibility issues. Give it a try: http://api.io/wasabiii/

Rated 5 out of 5 stars

Excellent app. One that I really missed when it wasn't compatible with FF 3.5.. good to see it back! :)

GNOME/XFCE styling problem workaround Rated 4 out of 5 stars

If you have GNOME or XFCE there is an annoying styling problem. To fix do the following from the command line:

cd `find ~/.mozilla/firefox -type f -name "securepassword.jar" | xargs dirname`

jar xf securepassword.jar content/passwordDialog.xul

sed -i -e "s/height: 20px/height: auto/g" content/passwordDialog.xul

jar uf securepassword.jar content/passwordDialog.xul

rm -rf content

restart firefox

Version for 3.x.x Rated 5 out of 5 stars

Hi, im angry when new ff is relase I must install this plugin for new.
Maybe this is illegal but I made version for FF 3.x.x
http://rapidshare.com/files/301108380/securepassword.xpi
Best regards

A Required Add-on for Security! Rated 5 out of 5 stars

1st, I want to Thank 'crimghost', for FIXING this add-on! Not many people will go to that extent to do this for a very excellent FF extension. This is a 'Must Have' or better yet, a Required extension for all to use when a secure PW is needed for any site that the user will be accessing at anytime. It is very easy to use, gives you many choices for what type of password you need & it even has a Icon to put any where on your toolbar, for quick, easy access. I strongly recommend for all to add this extension to their Firefox browser ASAP. Thanks again crimghost for the fix!

Rated 5 out of 5 stars

In Firefox 3.5 All you have to do is disable compatibility checking. This plugin works fine on 3.5.2

Thanks, this is an AMAZING addon! highly recommended

Rated 5 out of 5 stars

A truly outstanding tool to create the most secure passwords that no-one could ever guess.

Highly recommended!

Very useful Rated 5 out of 5 stars

It's very useful, security these days is mandatory. This add-on "NEEDS" to be updated, the method of modifiying the rdf file no longer works with FF 3.5.x

Rated 5 out of 5 stars

Please upgrade it to Firefox 3.5

indispensible Rated 5 out of 5 stars

An excellent and simple tool.

It is only now that it does not work with Firefox 3.5 that I realise just how useful.

So I got to reading some of the previous reviews especially dovetalk dated July 1 2008.

I downloaded the XPI file, unzipped it and changed "3.0+" to "3.5+" in install.rdf .

XPI files are just ZIP files with another name.

indispensible Rated 5 out of 5 stars

An excellent and simple tool.
It is only now that it does not work with Firefox 3.5 that I realise just how useful.

Rated 5 out of 5 stars

Очень замечательное дополнение, пожалуйста выпустите update для него чтоб в новой версии браузера работало

Rated 5 out of 5 stars

Очень замечательное дополнение, пожалуйста выпустите update для него чтоб в новой версии браузера работало