Needs an update Rated 3 out of 5 stars

It needs an update because of all the previous arguments.
The possible problem: html5 and new input type="email" which is not considered in the javascript code of the extension (I think it could be modified by an advanced user...).

This review is for a previous version of the add-on (  This user has 2 previous reviews of this add-on.