IMPOSSIBLE TO DOWNLOAD Rated 1 out of 5 stars

"you need a Mozilla-based browser, such as firefox, to install a plug-in"

What do you mean - I AM using Firefox..... why else would I try to download this add-on?

the problem is not in the plugin.