Updated for Firefox 4 Rated 5 out of 5 stars

Can't get in touch with the original developer. I've updated the plugin to be compatible with Firefox 4. Its available here: http://underhilllabs.github.com/2011/04/30/updated-the-scuttle-plugin-for-firefox-to-ff-4/