for FF 5 & 6 Rated 5 out of 5 stars

download .xpi file (with IE) -> open .xpi-file with winrar -> find 'install.rdf' file -> open with notepad -> change in that row '<em:maxVersion>4.*</em:maxVersion>' 4 to 6 -> save -> add saved 'install.rdf' file to .xpi-file -> save .xpi-file -> install add-on from file -> works!

This review is for a previous version of the add-on (1.4.12.1-signed). 

Rated 5 out of 5 stars

It dose help do:
http://lifehacker.com/355973/make-your-extensions-work-with-the-firefox-3-beta

# Type "about:config" into Firefox's address bar and click the "I'll be careful, I promise!" button.
# Right-click anywhere. Choose New>Boolean. Make the name of your new config value "extensions.checkCompatibility" and set it to "false".
# Make another new boolean pair called "extensions.checkUpdateSecurity" and set the value to "false".
# Restart Firefox.

This review is for a previous version of the add-on (1.4.2). 

Rated 5 out of 5 stars

Needed for FF 3.5!!

This review is for a previous version of the add-on (1.4.2).