Outdated dictionary! Rated 4 out of 5 stars

I love this tool but since firefox is being a bitch and not allowing unassigned add-ons to be installed to firefox, you need to get your updated dictonary files signed and approved by Firefox!

This review is for a previous version of the add-on (2.01.160101).