Thunderbird 6 compatibel Rated 5 out of 5 stars

Works brilliant with Thunderbird 6.0 (with Mozillas "Add-On Compatibilty Reporter")

This review is for a previous version of the add-on (7).