Version 0.6b3 not working with FF21 Rated 1 out of 5 stars

I had installed 0.5 and it was working great. Then I noticed that it had stopped working. I installed Version 0.6b3. It didn't work either. I have FireFox version 21.0