Worked well but no longer works since FF 31 Rated 4 out of 5 stars

Too bad !

Disable/remove this extension from Fx 30+

Please remove this extension from Fx 30+ versions and see if would help.