Rated 5 out of 5 stars

Really handy plugin. Can you update it to support Firefox 3.6? It seems to be compatible.

This review is for a previous version of the add-on (0.9.0).