Incompatible with version 24.4.0 Rated 5 out of 5 stars

I can confirm the incompatibility described by IM.

I'm using Debian's Iceweasel (which is just Firefox) version 24.4.0 and when trying to activate/install ReloadEvery the browser reports that it is incompatible with this version. It worked for years until now and ReloadEvery version 28.0.2 still works with Firefox version 24.3.0.