NO........! Rated 5 out of 5 stars

Please Don't Take it Away!!!!
I Loved this Extension untill FF 3.5 when it Became "Not Compatible! !!!"
I Consider this "A Must Have Tool !!!"
I Can't Stand Being without it, & I'm Going Back to 3.011 !!!

Hope it Comes Back Soon, as I really Liked 3.5

This review is for a previous version of the add-on (2.5.5).