FF 15? Rated 5 out of 5 stars

I successfully use Red Cats Blue Flavor with FF 14.0, Mac OS 10.7.4. I am now being "urged" to upgrade to FF 15, but will NOT do it unless someone can verify that it works with this latest version. Why are they upgrading FF versions so frequently?

I can't live w/o my cats!

This review is for a previous version of the add-on (5.5.2).