5 easy steps to make it work on FF 4.0 Rated 5 out of 5 stars

This is step by step workaround. Thanks to jandys!
1. Download QuickJava .xpi file - you can do this with another browser (not Firefox) - Opera, Chrome, Safari...
2. Extract the .xpi file - if your archive application can't do this, rename it to .zip and then extract
3. Fnd the file "install.rdf", open it with Notepad or such plain text editor. Find the text
<em:maxVersion>3.7a2pre</em:maxVersion>
(5th row from the end) and rename it to
<em:maxVersion>4.2</em:maxVersion>
(this is the highest version, so it could be even higher)
4. Compress it back again
5. Go to Firefox>>Add-ons and load the extension from external file - you will find this option in the top right button (the icon is like a gear-wheel)
That's it. It works perfectly. Tested!

This review is for a previous version of the add-on (1.7.2). 

Rated 5 out of 5 stars

Great! Perfectly works and it's nice!

This review is for a previous version of the add-on (1.7.2).