Compatiblity w/ 3.6 Rated 1 out of 5 stars

I need this to be compatible with FireFox 3.6 ASAP PLEASE!!!!!!!!!

This review is for a previous version of the add-on (0.1.8.1).