Still works for me! Rated 5 out of 5 stars

I've been using ProxySel for years, including with the new Firefox 3.6.14. You just have to select "Make Compatible." Positioned to the right of the menu bar, it takes up little space. I can't imagine a simpler proxy extension that works as well.