ProCon Latte + Firefox 6 (Final) = WORKS! Rated 5 out of 5 stars

I opened the xpi with 7-Zip and changed the install.rdf like Pro24 stated above to maxversion 7.0 and it now works! Thanks for the tip Pro24! I changed it to 7.0 in case I want to try the 7 alpha/beta. I tested it with version 7 alpha 2 and it works great.

If anyone needs a working version for Firefox 6 final you can get it at the link below. Unzip it then go into your add-ons and install it manually.

http://www.mediafire.com/?y86mvrut8mqe1or

This review is for a previous version of the add-on (1.7.9.7).  This user has a previous review of this add-on.