Rated 4 out of 5 stars

Great product easy to use works well with FF 4.x and 5.x - needed to be downloaded from the "View all versions page"

This review is for a previous version of the add-on (1.7.9.7).