doesn't work with 3.7a1pre Rated 3 out of 5 stars

Platypus does not work with 3.7a1pre (patched install.rdf) -- but Greasemonkey and Greasefire will work. Platypus worked with 3.6 -- might have been a recent build of 3.7 where it stopped working.