PingFire is broken with FF 3.6 Rated 3 out of 5 stars

Unfortunately, version 1.0.2 is not compatible with Firefox 3.6 :(

This review is for a previous version of the add-on (1.0.3).