Not compatible with 11.0. Rated 5 out of 5 stars

Not compatible with FF 11.0.

This user has a previous review of this add-on.